GUI

From jV

Jump to: navigation, search

Contents

Menu bar

The organization of the menu bar and the function of its components are shown below.

1) File menu
Component Function
Open - Local mmCIF A local mmCIF file is opened.
PDBML A local PDBML file is opened.
PDB A local PDB file is opened.
Polygon A local polygon file is opened.
Polygon CGO A local polygon CGO file is opened.
Script A local script file is opened.
Animation A local animation file is opened.
Open-Remote PDB ID A PDBML file at the PDBML FTP site is opened.
eF-site ID A set of molecular and polygon files stored in eF-site database are opened.
mmCIF A remote mmCIF file is opened.
PDBML A remote PDBML file is opened.
PDB A remote PDB file is opened.
Polygon A remote polygon file is opened.
Polygon CGO A remote polygon CGO file is opened.
Script A remote script file is opened.
Animation A remote animation file is opened.
Information Information about the selected files are shown.
Close The specified file is closed.
Save mmCIF A mmCIF format file that contains the current atom coordinates is created.
PDB A PDB format file that contains the current atom coordinates is created.
Script A script by which the present condition is reproduced is created.
PNG The current image is saved as PNG.
JPEG The current image is saved as JPEG.
Exit The application is terminated.
2) Display menu
Component Function
Wireframe The selected atoms are displayed in a wire frame model.
Backbone The selected atoms are displayed in a backbone model.
Sticks The selected atoms are displayed in a stick model.
Spacefill The selected atoms are displayed in a space-fill model.
Ball&Stick The selected atoms are displayed in a ball & stick model.
Ribbons The selected atoms are displayed in a ribbon model.
Cartoon The selected atoms are displayed in a cartoon model.
3) Colors menu
Component Function
Monochrome The selected atoms are colored in white.
CPK The selected atoms are colored by CPK color scheme.
Shapely The selected atoms are colored by the color scheme in which each amino acid and nucleic acid is assigned a unique color according to the amino acid and nucleic acid properties.
Group The atoms of every chain are drawn as a smooth spectrum from red (N-terminal of the molecule) to blue (C-terminal).
Chain The selected atoms are colored by the color scheme in which each chain is assigned a unique color.
Temperature The selected atoms are drawn as a smooth spectrum from red (high value) to blue (low value) according to the value of the temperature factor.
Structure The secondary structures are colored by the color scheme in which each secondary structure is assigned a unique color.
Charge The selected atoms are drawn as a smooth spectrum from blue (positive) to red (negative) according to the charge.
Amino The selected atoms are colored by the color scheme in which each amino acid is assigned a unique color.
4) Options menu
Component Function
Hetero Atoms Users can choose whether the heterogeneous atoms described by ‘HETATM’ in PDB files are selected or not.
Hydrogens Users can choose whether the hydrogen atoms are selected or not.
Slab Users can choose whether the z-clipping plane is located on the default position or is shifted.
Stereo Off Disables stereo display.
Wall-Eyed Enables side-by-side wall-eyed stereo viewing.
Cross-Eyed Enables side-by-side cross-eyed stereo viewing.
Red-Blue Enables red-blue anaglyph 3D rendering.
Red-Cyan Enables red-cyan anaglyph 3D rendering.
Red-Green Enables red-green anaglyph 3D rendering.
Load To Center Users can choose whether a new image is added to the center of screen or not when a new file is opened.
Pick Off The mouse-pick is disabled.
Ident The atom and residue names, their serial numbers, chain identifier and file ID of the object picked by mouse-click are represented.
Coordinates The atom and residue names, their serial numbers, chain identifier, file ID and coordinate of the object picked by mouse-click are represented.
Distance The distance between the first and second clicked atoms is calculated and shown.
Center The center of rotation and window are transferred to the clicked position.
Select Only clicked files are operated.
Animation The animation control dialog is opened.
5) Help menu
Component Function
About jV Information about this application is shown.
Open Manual A manual page is opened with a web browser.

Open-Local dialog

Selecting each menu item in the [File] – [Open – Local] menu opens the open-local dialog. For example, Figure 5 shows a dialog opened by the [File] – [Open – Local] – [mmCIF] menu item.

Figure5: The open-local dialog

Users can enter a local file path at the ‘Enter file’ text filed, or select a file by using a file chooser dialog that your operating system provides by clicking the ‘Browse…’ button. If a file ID that is already opened in the application is specified at the ‘fit’ text field, the transform of the newly opened file is set identical to that of the specified file. A biomolecule structure can be specified by entering assembly ID at the 'biomolecule' text field. For a biomolecule structure, a distinct model ID is assigned to each transform operation, which is listed by 'show information' command. Note that the biomolecule parameter is not available for flat PDB files. When a filter expression is entered at the ‘filter’ text field, only atoms that matches a given filter are loaded. The filter takes any atom expressions except some keywords (bonded, helix, sheet, turn, within and pdbj:). The atom expression should be double-quoted or enclosed in a parenthesis when it contains spaces.

Open-Remode dialog

1) URL with parameters

Selecting [mmCIF], [PDBML], [PDB], [Polygon], [Script] or [Animation] menu item in the [File] – [Open – Remote] menu opens the open-remote dialog that can handle a URL with parameters. For example, Figure 6 shows a dialog opened by the [File] – [Open – Remote] – [mmCIF] menu item.

Figure6: The open-remote dialog

When ‘Add’ button is clicked, a new parameter line is appended in the table at the center of the dialog. Figure 6 shows an example of a URL with one parameter. By clicking the ‘Add’ button the necessary number of times, you can attach multiple parameters. When ‘Remove’ button is clicked, a highlighted line in the parameter table is removed. When ‘Clear’ button is clicked, all parameters are removed.

Figure7: Example of a URL with a parameter
2)'type' column and mouse pick

The ‘type’ column in the parameter table is selected from the follows.

type values mouse pick
text arbitrary value does not work
atom ID atom ID work
atom set of chain ID, residue ID and atom ID work
residue set of chain ID and residue ID work
orig_coords atom coordinates written in the molecule file work
curr_coords atom coordinates currently displayed work

For the case of a type to which mouse pick works, selecting an atom in the screen by mouse pick sets the corresponding value to the ‘value’ column in a highlighted line in the parameter table. The value of the ‘delimiter’ field is used to delimit atom’s x, y, and z coordinate.

3) Saving and loading the configuration

By clicking the ‘save’ button, a file chooser dialog appears and the current configuration can be saved to a file. In the same way, a configuration can be loaded by clicking the ‘load’ button. The contents of a configuration file are in XML format as follows.

<?xml version="1.0"?>
 
 
<remote_file url="http://example.com">
 <params attach="true" coordinates_delimiter=",">
   <param name="param1" value="value1" type="text"/>
 </params>
</remote_file>
4) fit, biomolecule and filter

Three text fields entitled fit, biomolecule and filter work the same way as opening a local file. How to use them is described at the previous ‘Open-Local dialog’ section.

5) Execution

When the ‘OK’ button is clicked, a new file is loaded and the dialog is closed. When you use ‘Submit’ button, on the other hand, the dialog remains visible even after a new file is loaded.

Animation control dialog

The animation control dialog is visible only if [Options] - [Animation] menu is checked. When there is no animation file loaded, the animation control dialog is as Figure 7. If some animation files are opened, the animation control dialog is altered according to the number of the files. Figure 8 indicates the dialog in the presence of two files.

Figure8: The animation control dialog in the absence of files.
Figure9: The animation control dialog in the presence of two files.

Users can select which files are controlled by their checkbox. The frame position and playback and stop of the animation can be controlled individually to each file. The playback-speed and the selection of ‘loop’ and ‘swing’ modes are common for all files.

Personal tools